Torque Cars

audi a3 1.8t sluggish performance

Discussion in 'Audi forums' started by rossk187, 21 June 2010.

  1. rossk187

    rossk187 New member

    Messages:
    9
    From:
    Hertfordshire, WGC
    Car:
    A3 1.8 20V TURBO
    hi can anybody help me please, i have just changed the air filter back to the standard airbox and possibly broke the internal sensor, i can now smell fuel and noticed that the turbo is not boosting to what it used to. could the broken sensor be the problem?
     
  2. obi_waynne

    obi_waynne Administrator Staff Member Moderator

    Messages:
    41,331
    From:
    Deal, Kent UK
    Car:
    A3 1.4 TFSI 150 COD
    Try this ... Unplug the sensor and see if it is still running the same.
     
  3. pgarner

    pgarner TC ModFather Moderator

    Messages:
    16,521
    From:
    Lockerbie, SW Scotland
    Car:
    Octy smoke machine
    yup you could have broken the MAF. they arent the most robust of sensors and vag parts are even worse.
     
Loading...

Share This Page

Click Here
  1. This site, like pretty much every other site, uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are agreeing to our use of cookies, this may include third party cookies from our carefully selected advertising partners and for our analytics which allow us to see which pages are of interest and improve our site navigation and experience.
    You can disable cookies in your browser but this may affect your experience on this website.

    Dismiss Notice